This is a public Forum  publicRSS

Forum post

    fmsadmin Command Line tool not working on Lion Server
    Forum post posted August 12, 2011 by Todd Geist , last edited April 4, 2012
    5873 Views, 26 Comments
    Title:
    fmsadmin Command Line tool not working on Lion Server
    Your post:

    hello,

    I am aware that FileMaker Server 11 is probably not certified for Lion Server. However I am just trying to confirm if the issue I am having just a problem with my server.

    if I run the command

    fmsadmin -u Admin -p pswd LIST files

    I get this error

    fmsadmin: Permission denied.
    Error: 9
     
    I am absolutely certain that I have the right user name and password. It is just not working.  I already re-installed FileMaker server.
     
    Can anyone confirm that fmsadmin command line tool works on Lion Server?
     
    Thanks
     
    Todd

    Answer

    • TSDuck

      Hi Todd Geist1591:

      Thanks for posting.

      FileMaker Server 11 is compatible with Mac OS X Lion.  The command line functionality should work while in the Mac OS X Lion environment as well. 

      Does your username and password work correctly logging into the admin console?

      Have you tried using just fmsadmin -u Admin -p pswd?

      The following steps can be used to reset the username and password used for the admin console.  Be aware using these steps will delete any schedules and non-default settings being used. 

       

      1. In the admin console, stop the database server.

      2. Navigate to /Library/FileMaker Server/Admin/conf

      3. Delete these 4 xml files.

      managerconfig.xml

      server_config.xml

      wpe_workerconfig.xml

      ws_workerconfig.xml

      4. Reboot the FileMaker Server machine.

      5. Open a web browser and go to http://localhost:16000

      You can now specify a new username and password.  Try using the new username and password in the command line.  Let me know if this helps with your issue.

       

      TSDuck

      FileMaker, Inc.

    • Todd Geist

      Hello,

      Thanks very much for the repsonse. But sadly it didn't help.

      I am very certain of the password. I can log into the FileMaker Admin Console just fine.  I can also use fmsadmin HELP. but anything that requires authentication does not work.

      fmsadmin -u Admin -p pswd LIST files
      fmsadmin: Permission denied.
      Error: 9

      I did however do what you suggested, but it didn't solve the problem.

      You say that FileMaker Server is compatible with Lion, but I am not sure if you meant Lion or Lion Server. I know that Lion Server is just an application rather than a whole different OS, BUT it still could be the issue.

      I am running Lion Server and it is still not working.

       

      Thanks


      Todd

    • maser

      I just tried this and it worked on my Lion Server running FM 11.0v3 server:

       

      root# fmsadmin -u Admin -p <myPW> LIST files
      filemac:/Server HD/Library/FileMaker Server/Data/Databases/OTT Invoice mailing labels.fp7

       

      (That's the only file I'm hosting on this test database while we determine if we can get by without IWP until October (!) to update our production server...)

       

       

      Did you try "sudo fmsadmin..."?  (I ran as root above...)

    • Dominique Bunzli

      Hello,

      I have the exact same problem on a fresh Lion client 10.7.2 install with latest filemaker pro server 11.0.4.

      If I input in the terminal

      fmsadmin CLOSE

      fmsadmin: really close database(s)? (y, n) y
      fmsadmin: Connection Refused: Server is unavailable.
      fmsadmin: Permission denied.

       

      If I input the same with login and password

      fmsadmin -u login -p password STOP SERVER


      fmsadmin: really stop SERVER? (y, n) y
      fmsadmin: Permission denied.
      Error: 9

      The whole server is working very well with the Admin Console GUI so I am sure the login and pass are right.

      Very annoying.

      Thanks for helping us.

    • Dominique Bunzli

      Forgot to say that I tried with sudo and that this doesn't change anything.

    • Dominique Bunzli

      Hello Filemaker,

      Can someone from Filemaker tell us at least what is the "error 9" and "error 10006", as it is not in the documentation.

      Thanks.

    • TSGal

      Dominique Bunzli:

      Thank you for your posts, and I apologize for the late reply.  Special thanks to "PhilModJunk" for notifying me of this post.

      A similar problem has been reported to our Testing department with FileMaker Server 11 and Mac OS X Lion, but Testing was unable to replicate the problem.  In essence, the Stop command from the Command Line was issued without any error message, but Start would retrurn error 10006 and Restart Server returned error 10007.  Restart with xDBC returned error 10007, and List Files/Clients returned error code 10502.

      Error 9 is not having the necessary permissions.  Error 10006 is a general Start error.

      I have logged your posts as a new issue, relating it back to the previous issue.  I will keep you posted as information becomes available to me.

      TSGal
      FileMaker, Inc.

    • TSGal

      Dominique Bunzli:

      A few testers were unable to replicate the problem.  They were able to close files from the command prompt and able to verify other commands such as send message, open file, list files, list schedules, etc.

      Tests were run on a Mac Mini, a MacBook Pro, and one virtual machine without any issues.  One tester had a similar issue, but it turned out the machine was improperly installed as many applications other than FileMaker also had issues.  Once the OS was reinstalled along with FileMaker Server, the errors were no longer present.

      Since more than one customer has reported this issue, Testing is continuing to pursue this, but they need additional help.  They ask that you reinstall Mac OS X 7 and reinstall FileMaker Server 11.0v4 and to try again.  Please continue to keep me updated.

      TSGal
      FileMaker, Inc.

    • Dominique Bunzli

      Hello,

      Thanks for your feedback. Unfortunately I am not able to test this before a few weeks. I eventually will and get back here as soon as I have. Until then, I stay with snow leopard. Thanks.

    • Beatrice Beaubien

      Hello TSGal,

      I also can't start FMS 11.0v3 (Windows Server 2008 R2) from the Command Line. The following returns an error of 10006:

      fmsadmin START SERVER -u <username> -p <password> -y

      Disconnecting clients, closing files and stopping the server all run fine. Starting Server from the Admin Console is also fine. Any advice would be gratefully received.

       

      Best wishes,

      Beatrice Beaubien