This is a public Forum  publicRSS

Forum post

    thuidor
    Having Problems with Instant Web Publishing
    Forum post posted March 3, 2009 by thuidor , last edited February 9, 2012
    492 Views, 17 Comments
    Title:
    Having Problems with Instant Web Publishing
    Post:

    I am trying to use Filemaker's IWP to host a database and am having difficulty getting this feature to work.

     

    So far, I have enabled IWP within the database and have tried using various port numbers but still can not get the database to show up. I can access the web page that Filemaker generates but I get the message "No databases available" displayed on the web page.

     

    In addition, in the IWP option screen within the Filemaker client the "Currently open files" field is blank.

     

    I've enabled the database via the client but can not get it to show up in this field. Am I missing something or is this a firewall/port or server issue? 

    Answer

    • jonnyt
      Are you using the FM Pro only or FM server ?
    • TSGal

      thuidor:

       

      If the FileMaker generated page is appearing and the "Currently open files" remain blank, then you may not have set the access properly.

       

      Open the file, pull down the File menu and select "Sharing -> Instant Web Publishing...".  At the top, you probably already have Instant Web Publishing turned on.  That's fine.

       

      The lower left area shows the currently open database files.  Select the table you want to show via Instant Web Publishing, and now on the right side, it should show you the access privileges to the file, and I bet it is set to "No users".  Change this to "All users" and then try opening this remotely from a browser.  The file should now show up.

       

      TSGal

      FileMaker, Inc. 

    • mikeyh

      I am getting the same error- "No databases available."  The sharing is configured properly and I can and All users can access it but it does not show up.

       

      Could it be a firewall problem?  I know some of my filemaker properties have been disabled.

       

      Thanks!

    • TSGal

      mikeyh:

       

      Thank you for your post.

       

      If you are getting the FileMaker web screen with "No databases available", then you are getting to FileMaker Pro through the firewall, so that is not the problem.  I would double-check one of the files under Instant Web Publishing, and make sure the access is set to "All Users".  This is the most common problem.

       

      TSGal

      FileMaker, Inc. 

    • chuckg

      I've been using Instant Publishing for almost a year and all of a sudden it stopped working and users get "No databases available".

      I haven't made any changes to this setup that I know of.

      Filemaker 9.0v3

      Mac OSX 10.5.6 

       

      Sharing -> Instant Web Publishing... 

      Instant Web Publishing: On (otherwise there would be no "no databases available" message) so that is working.

      For the selected file "All users" is selected and "Don't display..." is off.

      Advanced Options: Accessible only from these IP addresses is off

       

      Manage -> Accounts & Privileges -> Accounts: all users have [Full Access] except [Guest]

      Manage -> Accounts & Privileges -> Privilege Sets: [Full Access] Access via Instant Web Publishing (fmiwp) is checked

      Manage -> Accounts & Privileges -> Extended Privilege: On for all privilege sets 

       

      No error message in the log. Only:

      queueing privileged task wc:: KillDeferredTasks with address 0x01A430E0 ( obj == 0x01A430E4 ) into queue sOnStaticExit

      queueing privileged task wc:: PoolingSchedulerImpl with address 0x01A42B64 ( obj == 0x01A42B74 ) into queue sOnStaticExit 

      when starting up fmiwp 

       

    • TSGal

      chuckg:

       

      Thank you for your post.

       

      1. Create a new database file with one field and enter one record.

      2. Turn on Instant Web Publishing, write down/verify the IP address (and port), and set the file for access "All Users".

      3. Go to the second computer, launch a browser, and enter the IP address (and port if applicable).

       

      Does the new database appear?

       

      If so, then there is something inherent to that original file.

       

      If not, then there is something not allowing the database to be seen.

       

      Create a new user account and see if you can turn on IWP from that user account.

       

      Try removing the FileMaker preference file in your user directory (com.filemaker.pro.plist or com.filemaker.filemakerpro.plist, depending on version).  Also, you can remove the FileMaker Preferences folder.  Quit, remove the file and folder, and launch again.  FileMaker will see the preferences file(s) is missing, so a new one will be created.

       

      Please continue to keep me updated with your progress.

       

      TSGal

      FileMaker, Inc. 

    • chuckg

      TSGal wrote:

      chuckg:

       

      Does the new database appear? 

       

      answer: no 

       

      Create a new user account and see if you can turn on IWP from that user account.

       

      answer: Yes it can turn IWP on 

       

      Try removing the FileMaker preference file in your user directory (com.filemaker.pro.plist or com.filemaker.filemakerpro.plist, depending on version).  Also, you can remove the FileMaker Preferences folder.  Quit, remove the file and folder, and launch again.  FileMaker will see the preferences file(s) is missing, so a new one will be created.

       

      answer: trashed all that stuff and it still doesn't work

       

      response to browser is very very slow. like IWP is trying to access FM but doesn't get thru and times out. 

       

    • TSGal

      chuckg:

       

      In case there is a port conflict, set the port number in FileMaker to 591.  This port is registered and reserved for FileMaker.

       

      Next, launch a browser on the same machine where FileMaker is hosting the file and enter:

       

      http://<IP address>:591

       

      The database(s) should now appear.

       

      If that works, then try launching a browser from the second machine and enter the same address.  This will help narrow down some possibilities.

       

      TSGal

      FileMaker, Inc. 

    • chuckg

      TSGal wrote: chuckg:

      In case there is a port conflict, set the port number in FileMaker to 591. This port is registered and reserved for FileMaker.

       

      I would think that if there were a port problem then the browser would never get a response.I was using 8080 and changed it to 591.

       

      Same response: No databases available.

       

      Something has to be blocking IWP from getting at Filemaker itself. Is there a port involved there? Are there any changes to MacOSX what would try to prevent IWP from talking to Filemaker for some reason? On the other hand, if IWP couldn't talk to FileMaker then wouldn't there be a better message than "no database available"? Such as "no FileMaker available"?

    • TSGal

      chuckg:

       

      If there were a port problem, it may very well be that you never get a response.  For example, if FileMaker Pro is not open, then you should get a "Failed to Connect" error message, which confirms what you are saying.  However, I wanted to eliminate any possibility of that happening and suggested using port 591 which is reserved for FileMaker Pro.

       

      On my machine, I have FileMaker Pro open without any files, and Instant Web Publishing is turned on.  On the second machine, I access the first machine using port 591, and I get the "Instant Web Publishing" web page with "No databases available".

       

      I then open a database file, go into "Sharing -> Instant Web Publishing", select the file under "Currently open files" and set access to "All users".  When I reset the browser on the second machine, my database now appears.

       

      If something was blocking Instant Web Publishing, then you wouldn't receive the Instant Web Publishing page.

       

      In my System Preferences -> Sharing, I only have File Sharing and Web Sharing checked.

       

      I have created a test file with all the correct settings that opens for me with Instant Web Publishing.  I have sent this file to our Technical Support contact person, and I'll have him email it to you to test.

       

      TSGal

      FileMaker, Inc.