This is a public Bug Report  publicRSS

nouveau signalement

    smel
    FileMaker10 Format de dateAnswered
    nouveau signalement posted February 17, 2009 by smel, last edited February 9, 2012 
    396 Views, 5 Comments
    Description du problème:
    En FileMakerPro 10, dans la section "Option de fichier..." du menu "Fichier"; dans l'onglet "Texte"; lorsqu'on active l'option "Toujours utiliser les paramètres du système en cours" on fait en sorte que FileMaker se conforme avec les réglages de l'OS. Cette option est vitale pour conformer les format de dates et éviter toute confusion dans l'exécution des scripts. FileMaker 10 omet ce paramètre quand il exécute la fonction de script "Insérer résultat du calcul". Par conséquent, si on utilise cette fonction pour insérer une plage de dates provenant d'un calcul réalisé sur des rubriques dates dont leur création remontent à FM7 (DateDébut & "..." & DateFin), la plage de dates insérée par ce calcul aura le format de date d'origine de la base de données (JJ/MM/AAAA) et causera une erreur d'exécution du script. J'ai un petit fichier de démonstration de ce bogue. Merci. 

    Best Answer

    smel

    Je vous remercie de votre conseil. Cela a effectivement réglé le problème de format de date. Comme vous le mentionnez, le clone a utilisé mes réglages régionaux comme format de date par défaut.

     

    Stéphane 

    Answer

     

    • TomK

      Bonjour,

       

      Est ce que vous constatez le même comportement si vous créez un clône sans enregistrements de ce fichier et exécutez ensuite ce script ?

      En effet le clone sans enregistrement a pour particularité de recréer un fichier avec les nouveaux réglages régionaux en cours par défaut.

       

      Cdt, 

      Tom. 

    • smel

      Je vous remercie de votre conseil. Cela a effectivement réglé le problème de format de date. Comme vous le mentionnez, le clone a utilisé mes réglages régionaux comme format de date par défaut.

       

      Stéphane 

    • monsieurmickael

      Bonjour,

       

      Ah ! Je suis content je galère depuis 2heures avec exactement ce problème ! Comment avez-vous fait pour créer un clone vide ? une copie de la base (car ca ne change rien ...) ?

      Info : je suis sur FMP11 

    • MLansard

      Bonjour,

       

      Menu "Fichier > Enregistrer une copie..."

       

      Puis Type = "Clone sans enregistrement" 

       

      Cordialement 

    • TomK

      Bonjour,

       

      Comme le dit Michel c'est dans le menu Fichier > Enregistrer une copie

       

      Ensuite dans la boite de dialogue vous devez choisir Clone sans enregistrement

       

      Screen shot 2010-05-21 at 16.23.34.png

       

       

      Cdt,

      Tom.