This is a public Forum  publicRSS

Forum post

    Arch
    How to Set Default Font?
    Forum post posted February 9, 2009 by Arch, last edited February 9, 2012 
    1191 Views, 7 Comments
    Title:
    How to Set Default Font?
    Post:
    I am currently using Filemaker Pro 7 (yes I know its old) and I read online somewhere that I should be able to set a default font so that every time I place an entry I do not have to change the font and size for each line.  Could someone please tell me how in detailed steps do I go about setting this default font? Thank you.

    Answer

     

    • raybaudi
      Hi Arch

      1) Go to Layout Mode
      2) Without selecting anything choose the font
      3) Go to Browse Mode.
    • Arch

      Thank you for your advice Raybaudi, but it still is not working. 

      I switch to layout mode, then go into format and select the font and font size, then switch to the browse mode and it still is not working!!! what am i doing wrong?

    • raybaudi
      > what am i doing wrong?

      Nothing...

      The default font and size are NOW what you are chosed, but all previous fields and text objects are formatted with the OLD default font and size.

      Try to add a new field and you'll see the difference.
    • TSGal

      Arch:

       

      The answer from "raybaudi" is correct  (Thank you!).  However, for existing fields, go into Layout Mode and shift-click each of the existing fields you want changed, pull down the Format menu and select the appropriate font.  This will then change the way data is entered into those fields.

       

      Let me know if you are still running into difficulty.

       

      TSGal

      FileMaker, Inc. 

    • Alan Ullman

      How can I change the font and size for information that was pasted in? Many of the entries have pasted in information with styles/fonts that are not my default and it would be a lot of work to do each entry and field separately.

    • PhilModJunk

      The best method is to use an auto-enter calculation to strip out the formatting. This will affect pasted in formatting on Macs (windows pastes unformatted, at least in XP) and also formatting applied when the user selects text in the field and applies a text format via the formatting toolbar.

      TextFormatRemove ( Self )

      Then clear the "do not replace existing value..." option.

      This assumes that you are using a new version of FileMaker than 7 like the original poster. If you are using an older version, you will need to use the actual name of the field in place of "self" in this expression.

    • Alan Ullman

      I'm using FM 11.

      Would this work with the current, already entered data to change it to my default? If so, how do I go about doing it?

      Is it easier than exporting all entries as text and then importing them?

      Alan